Welcome to mirror list, hosted at ThFree Co, Russian Federation.

github.com/twbs/bootstrap.git - Unnamed repository; edit this file 'description' to name the repository.
summaryrefslogtreecommitdiff
path: root/js
AgeCommit message (Expand)Author
2022-01-29event-handler.js: use `for...of`XhmikosR
2022-01-29Rename variablesXhmikosR
2022-01-29backdrop.js: cache `_getElement` callsXhmikosR
2022-01-29Remove a few unneeded variablesXhmikosR
2022-01-13Fix: `isVisible` function behavior in case of a `<details>` element, on chrom...Ryan Berliner
2022-01-05Remove explicit use of aria-hidden for offcanvas when closed (#35589)Patrick H. Lauke
2021-12-21Carousel: move repeated code to a methodGeoSot
2021-12-21Carousel: remove always true `visibilityState` checkGeoSot
2021-12-21Carousel: move carousel default interval to `_getConfig()` and simplify itGeoSot
2021-12-21Carousel: return early and drop a loop.GeoSot
2021-12-21Carousel: add a helper to get the active elementGeoSot
2021-12-21Popover/Tooltip: Fix vertical alignment on arrow of tip elements (#35527)GeoSot
2021-12-18Fix typo in comment (#35564)Phil E. Taylor
2021-12-15Tooltip: remove extraneous call to _getConfig() (#35540)GeoSot
2021-12-15Popover.js: Accept empty content through `data-bs-content` (#35514)GeoSot
2021-12-15Scrollspy: minor refactoring (#35512)XhmikosR
2021-12-10Extract Component config functionality to a separate class (#33872)GeoSot
2021-12-10Tab: minor refactoring (#35511)XhmikosR
2021-12-10util/index.js: minor refactoring (#35510)XhmikosR
2021-12-10Toast: join multiple classList calls (#35507)XhmikosR
2021-12-09Fix tests fixture type (#35501)XhmikosR
2021-12-09Scrollbar - remove margin/padding properties properly (#35388)GeoSot
2021-12-09Dropdown: fix toggle focus after dropdown is hidden using the `ESC` button (#...GeoSot
2021-12-09ScrollBar.js. Minor refactoring and add test (#35492)GeoSot
2021-12-07Tooltip: remove title attribute before show & add tests (#35456)GeoSot
2021-12-02Tests: Minor fixes (#35455)Louis-Maxime Piton
2021-12-01Tooltip/Popover: add underscore prefix to protected functionsGeoSot
2021-12-01Tooltip: a simple code-block position changeGeoSot
2021-12-01Tooltip: simplify popper checkGeoSot
2021-12-01Tooltip: refactor `_hoverState` to Boolean to achieve better controlGeoSot
2021-12-01Tooltip: merge timeout functionalityGeoSot
2021-12-01Tooltip: Change `_enter` & `_leave` to work without argumentsGeoSot
2021-12-01Tooltip: Remove redundant `config.delay` checkGeoSot
2021-12-01Tooltip: Remove `Data.set` usage for dynamically created tipGeoSot
2021-12-01Tooltip: merge `isAnimated` checksGeoSot
2021-12-01Tooltip: refactor jQueryInterfaceGeoSot
2021-12-01Dropdown: clearMenus is always an event callbackGeoSot
2021-12-01Dropdown: Clean moreGeoSot
2021-12-01Dropdown: rename varsGeoSot
2021-12-01Dropdown: Remove redundant `Space` checkGeoSot
2021-12-01Dropdown: Deduplicate complex checkGeoSot
2021-12-01Dropdown: Remove redundant check since the `show` method already does itGeoSot
2021-12-01Dropdown: Change constant to the way we use itGeoSot
2021-12-01Dropdown: Merge `display='static'` & `isNavbar` functionality activating stat...GeoSot
2021-12-01Dropdown: Remove static method used onceGeoSot
2021-12-01Dropdown tests: Use a function to improve readability (#35448)GeoSot
2021-12-01Fix popover arrow & tooltip template after the `setContent` addition (#35441)GeoSot
2021-12-01Tooltip: remove leftover method (#35440)GeoSot
2021-12-01tests/unit/util/scrollbar.spec.js: rename functionXhmikosR
2021-12-01tests: fix a few typosXhmikosR