Welcome to mirror list, hosted at ThFree Co, Russian Federation.

git.blender.org/blender.git - Unnamed repository; edit this file 'description' to name the repository.
summaryrefslogtreecommitdiff
AgeCommit message (Collapse)Author
2020-12-15Blenloader: Add utility function to write double arrayHans Goudey
It makes sense to support writing double arrays just like floats. This is just split from a patch (D9697) to slim it down some.
2020-11-06Blenloader: access report list via apiJacques Lucke
2020-11-06Blenloader: expose BLO_reportf_wrap in apiJacques Lucke
This function is used by a couple of functions that are moved out of blenloader.
2020-11-06Refactor: move Scene .blend data reading to IDTypeInfo callbackJacques Lucke
2020-11-06Refactor: move wmWindowManager .blend I/O to IDTypeInfo callbacksJacques Lucke
2020-10-30Refactor: move WorkSpace .blend I/O to IDTypeInfo callbacksJacques Lucke
2020-10-30Refactor: move bScreen .blend I/O to IDTypeInfo callbacksJacques Lucke
I could not easily move `direct_link_screen` yet, because it has a return value. That has to be solved differently at some point.
2020-10-30Refactor: move Area .blend I/O to blenkernelJacques Lucke
There should be no functional changes. Eventually, it would be good to handle the different space types using callbacks. Ref T76372.
2020-09-30Cleanup: sort struct declarationsCampbell Barton
2020-09-20Sanitize type 'size' parameters in our read/write file codeBastien Montagne
This patch tries to sanitize the types of our size parameters across our read and write code, which is currently fairly inconsistent (using `int`, `uint`, `size_t`...), by using `size_t` everywhere. Since in Blender file themselves we can only store chunk of size `MAX_INT`, added some asserts to ensure that as well. See {T79561} for details. Differential Revision: https://developer.blender.org/D8672
2020-09-11Refactor: move Volume .blend I/O to IDTypeInfo callbacksJacques Lucke
2020-09-04Cleanup: Clang-Tidy readability-inconsistent-declaration-parameter-name fixSebastian Parborg
No functional changes
2020-08-28Blenloader: add api function for accessing packedfile address mapJacques Lucke
This is needed to move direct_link_packedfile out of readfile.c for T76372.
2020-08-28Blenloader: new api function to check if reading is for undoJacques Lucke
2020-08-07Code Style: use "#pragma once" in source directoryJacques Lucke
This replaces header include guards with `#pragma once`. A couple of include guards are not removed yet (e.g. `__RNA_TYPES_H__`), because they are used in other places. This patch has been generated by P1561 followed by `make format`. Differential Revision: https://developer.blender.org/D8466
2020-07-09Blenloader: make BLO_read_data_address work in C++Jacques Lucke
2020-06-06Blenloader: simplify list reading apiJacques Lucke
2020-06-05Blenloader: new write_struct_at_address api functionsJacques Lucke
2020-06-05Refactor: use compile time dna struct ids in blenloader apiJacques Lucke
2020-06-05Refactor: use new api for writing linestyle, cachefile, hair, pointcloud, ↵Jacques Lucke
volume and simulation
2020-06-05Blenloader: New API that will be used for blenloader decentralizationJacques Lucke
Design Task: T76372 This part of a larger refactoring towards a more extensible architecture in Blender: T75724 The API is defined in `BLO_read_write.h`. It adds the small data structures `BlendWriter`, `BlendDataReader`, `BlendLibReader` and `BlendExpander`. Those contain context about the current read/write operation. Furthermore, it adds many functions with the prefixes `BLO_write_*`, `BLO_read_*` and `BLO_expand_*`. Lib linking and expanding will probably be handled by the more generic libquery system eventually. The corresponding parts of the API can be removed then.