Welcome to mirror list, hosted at ThFree Co, Russian Federation.

git.blender.org/blender.git - Unnamed repository; edit this file 'description' to name the repository.
summaryrefslogtreecommitdiff
AgeCommit message (Collapse)Author
2014-09-24gooseberry request:Antony Riakiotakis
Attempt to select closest bones when possible. Occlusion query selection does't support this well because we can't really derive depth information from occlusion tests. May be possible to improve this somewhat in the future.
2014-07-31Style cleanupCampbell Barton
2014-07-29Fix T41228: Selection of bones bug.Bastien Montagne
Turns out to be mostly some cleanup in Pose select code, got rid of magic numbers (now understand usual SEL_xxx enums) in ED_pose_deselectall(), which was renamed to ED_pose_de_selectall, and have a new bool parameter to ignore visibility status in its process (was the root of the reported issue). Also factorized slightly "(de)select all" code. Yet this area could use much more cleanup probably...
2014-07-19Defines: replace ELEM3-16 with ELEM(...), that can take varargsCampbell Barton
2014-07-06Fix for typo in commentJoshua Leung
2014-07-03Select Grouped -> KeyingSet for bones also shows error messages now when the ↵Joshua Leung
Keying Set is inappropriate
2014-07-03Code Cleanup - Replaced magic numbers with definesJoshua Leung
2014-04-30Code cleanup: remove unused includesCampbell Barton
Opted to keep includes if they are used indirectly (even if removing is possible).
2014-04-11API Cleanup: Use BKE_constraint prefix for constraint apiCampbell Barton
2014-04-01Code cleanup: remove TRUE/FALSE & WITH_BOOL_COMPAT defineCampbell Barton
2014-02-03Code cleanup: use bools where possibleCampbell Barton
2013-11-25Code Cleanup: rename vars for detecting change to be more consistentCampbell Barton
rename change/is_change/is_changed/modified -> changed also use bools over int/short/char and once accidental float.
2013-11-25T37247 - Modifier "Mask" not updated correctly when switching from objectsHenrik Aarnio
2013-11-18Fix T37336: Toggle selecting a pose-bone from object mode would de-select ↵Campbell Barton
all others.
2013-11-16pose mode: extend selection flipping to use the same method as editmode.Campbell Barton
adds extend and active only opton.
2013-11-16armature editmode: option for select mirror to use active bone only.Campbell Barton
2013-11-16code cleanup: rename flip_side_name to BKE_deform_flip_side_nameCampbell Barton
2013-10-18Tweak for action group -> bone select featureJoshua Leung
Set newly selected bone as "active", so that the transform properties show the correct values for the newly selected bone
2013-10-17Project Pampa Request: Selecting groups in animation editors selectsJoshua Leung
corresponding bones
2013-07-28use '_exec' suffix for operator execute callbacks, also picky change to ↵Campbell Barton
sizeof() use in BLI_array.h
2013-03-20code cleanup: use booleans for mesh and selection code.Campbell Barton
2013-03-13code cleanup: use const events for modal and invoke operators.Campbell Barton
2013-02-28code cleanup: includesCampbell Barton
2013-02-28Code cleanupsJoshua Leung
* Replace magic numbers with enum-defines * Remove superfluous return; statements (used as last statements in a few "static void" methods) * Remove some old unused/commented out stuff
2013-02-28Code Maintenance - Splitting up Armature/Pose Editing FilesJoshua Leung
This commit splits editarmature.c and poseobject.c into several files, such that certain types of functionality are (mostly) self-contained within particular files (instead of being mixed in with other functionality in a large file). In particular, this was done so that: 1) Armature EditMode tools are now in the armature_*.c files only, and Pose Mode tools in pose_*.c files only. - In one or two cases, this hasn't been possible as the two modes rely on much of the same shared infrastructure. 2) The "clear loc/rot/scale" operators and pose show/hide are no longer housed in editarmature.c 3) Selection operators, Transform operators, structural (add/delete) operators, and supporting utilities for the modes (enter/exit/roll-calculations) are not all interleaved in an ad-hoc manner Notes: * I've tried to ensure that the history of the new files has been maintained by doing svn copy {editarmature.c/poseobject.c} {armature_*.c/pose_*.c} Unfortunately, this means that the diffs are a bit messy. * There should be no functional/logic changes here. Just code moving around and cosmetic comment tweaks where needed. * #includes have largely been untouched for now, but could be cleaned up later * CMake changes untested, but should work in theory.