Welcome to mirror list, hosted at ThFree Co, Russian Federation.

git.blender.org/blender.git - Unnamed repository; edit this file 'description' to name the repository.
summaryrefslogtreecommitdiff
AgeCommit message (Collapse)Author
2010-08-17apply logic brick rna renamingCampbell Barton
2010-07-17- added text3d.body_format to be able to set bold/italic/smallcaps etc on text.Campbell Barton
- the length of a new text object wasnt set on creation. - tex3d and controllers rna name was being set to its body (rather then ID name) - remove reference to wave objects which are very old and not used anymore.
2010-07-17simplify thumbnail reading and remove some warningsCampbell Barton
2010-07-15Logic UI: Changing Controllers names to follow Sensors and actuators (back ↵Nathan Letwory
to have only the first latter capitalized) + change the controller state only when in expanded mode (show the number otherwise). Cosmetic commit, no structural/big code changes (patch by dfelinto).
2010-07-13Logic UI: HEADERS changes:Dalai Felinto
adding option to change state + showing the name, type as label when not-expanded + renaming rna prop "states" (from state_number) + small UI changes + capitalizing Controller Type names (as we had in 2.49). Why? I'm not sure. Therefore let's stick to 2.49 way of doing it for a bit longer. * It would be really nice to have a drag&drop system for logic (instead of the move up/down button) * The controller header is so messy :/ definitively should find a better way to handle that (for one the "change state" operator doesn't need this up/down arrow. I'm (temporarly) using the old code for that, so this will wait for when we use proper rna ui here. * I wonder if it's possible to get the name of the logic type straight from the rna prop (instead of using sensor_name(sens->type) )
2010-07-11Logic Editor Python API: link/unlink logics through pythonDalai Felinto
After initial talk with Matt (awhile ago) we realzed that rna_api would fit well for this instead of an operator. The next step would be to move the current UI code to use the rna funcs instead. Note: it takes the s/c/a as argument, not its name. (e.g. cont.link(actuator=act) ) Sample code to link all the logic bricks between each other: ob = bpy.context.object for cont in ob.game.controllers: for sens in ob.game.sensors: cont.link(sensor=sens) for act in ob.game.actuators: cont.link(actuator=act) For a script to create bricks, link bricks, unlink bricks and remove them: http://www.pasteall.org/14266
2010-06-28remove some warningsCampbell Barton
2010-06-17fixing warning from previous commit (rna_controller)Dalai Felinto
2010-06-16Logic UI: partial implementation of state per controllerDalai Felinto
Adding two rna properties: state and state_number For scripting "state_number" (integer) makes more sense while "state" (boolean/array) may be needed for the UI. So far the UI is only showing the state number (using Label). Still have to decide how is the better way to "change the state". If we don't need "state" (as boolean) for the UI, we can have only the integer one and rename it to "state". + some cosmetic changes (renamed ob "states" to "visible states") ps.: 2 goals == 2 commits... let's see if I can keep that ratio until the middle of July ...
2010-05-08Logic UI: add notifiers for sensors and controllers (so the ui updates if ↵Dalai Felinto
you change the value through script) + some layout adjusments.
2010-05-06Logic UI: constraint actuator+rna 100% (finally !!!) + other fixes/improvements:Dalai Felinto
- s/c/a type enum update function replaced by set function - rna_Sensor_type_itemf and rna_Actuators_type_itemf implemented (but not working ... it was working yesterday before I updated the set func, so need further investigation). Matt, if you have any clue on that ... Roadmap: i) I definitively gotta unify the maxloc, minloc rna properties. the way it's right now (based on 2.49 makes the layout code really clunky ii) - actuator missing - State Actuator (I'll probably need help on that). iii) - sensor missing - collision and ray (they are partly implemented, but the enums are a mess there). iv) - get/set funcs missing (not many) and default values (not many) v) - have more lookup functions for properties and material (I'll definitively need help on that). Eventually will fix (iii, iv and v) changing bge and dna code and doing a subversion/do_version.
2010-05-04BGE Logics UI: commit to receive some feedback from MattDalai Felinto
To test use debug mode > 0 (Ctrl+Alt+D) * primarly the goal is to put all the bricks there, and then to worry about the proper layout * sensor header added (need to be more compressed). Also checkbox will not work that well here in my opinion. we need to see what can be used instead (icons?) * sensors, and actuators in alphabetical order * a lot of sensors using the rna (//XXXSENSOR in the ones not using it) * the logic_window.c code for controller and actuator is there only to display the draw functions for controller and actuators. But the code it's a really bad copy of the sensor code, so it will be fixed later (Matt? :) * I would love if the non-expanded mode were more compact, more like in 2.49 (the name non-editable). but this is the kind of think we can worry in the end. Also instead of "move up/move down" it would be nice to drag/drop the sensors/controllers/actuators * to do: rna_actuators: to rename type to mode for the enum
2010-03-24remove unused rna includesCampbell Barton
2010-03-22spaces -> tabs, (4 spaces == 1 tab, only for white space preceding text)Campbell Barton
2010-02-12correct fsf addressCampbell Barton
2010-02-11batch remove .'s used with RNA_def_struct_ui_textCampbell Barton
2010-02-06BGE: rna update for Logic BricksDalai Felinto
Sensor and Controllers: small fixes and suggestion (comments) for future improvement - mainly to replace text properties to material, text or object datablocks. Actuators done: * IPO * CAMERA Actuators to be done: All the others (their structure is in the file) Adding NC_LOGIC ** If someone want to help on that: Files used for actuator RNA: - logic_window.c - DNA_actuator_types.h *** my first big RNA operation. critics/suggestions are welcome **** padded some DNA variables that were not been used.
2009-06-16RNABrecht Van Lommel
* Added icon to property and enum property items. The latter is responsible for the large number of files changed. * For RNA functions, added PROP_RNAPTR flag to ask for a PointerRNA as argument instead of a C pointer, instead of doing it implicitly with the AnyType type. * Material: properly wrap diffuse/specular param variables, and rename some things for consistency. * MaterialTextureSlot: added "enabled" property (ma->septex). * Image: make animated property editable. * Image Editor: make some things editable, notifiers, respect state. * Context: fix issue with screen not being set as ID.
2009-05-29RNA:Brecht Van Lommel
* Automatically do us++ and us-- reference counting in ID pointer set functions. * Added an enum property callback to dynamically vary the list of available items. * Added some functions to do removes on pointers and collections runtime defined for RNA and using ID properties. * Constraints now have owner/target space wrapped, and most pointers made editable. They can be ported to use python layouts. * Also other pointers made editable that I think are see now with the automatic reference counting.
2009-03-23RNA:Brecht Van Lommel
* Allow pointers to be editable, did SpaceTextEditor.text as a test. * Changed PROP_NOT_EDITABLE to PROP_EDITABLE, and added RNA_def_property_clear_flag. * Removed rna_dependency.c test code.
2009-01-11RNABrecht Van Lommel
* Finished DNA_lamp_types.h, DNA_world_types.h and DNA_sound_types.h. * Renamed "parent" struct property to "nested", and also remaining "from" usage to "base". * Added a NEVER_NULL subtype for pointers and use it for all properties that apply. * Make sure all structs have a description, and fix any other DOC_BROKEN descriptions, also many other naming consistency improvements.
2009-01-02RNABrecht Van Lommel
* Added skeleton code for particle/object_force/userdef. * More Object properties wrapped. * Added User Preferences display in outliner.
2009-01-01RNABrecht Van Lommel
* Added support for sending notifiers and updates when setting RNA properties. Per property, there is a notifier NC_/ND_ flag, and a function that is called. Currently only used for Object.loc/rot/size. * RNA_property_update that does this is not automatically called in every _set function, it has do be done separate, and is being done by buttons with RNA data. * Perhaps for python there could be a trick to accumulate these flags rather than update each time, though for now the python RNA code could just do them everytime. Did not add these calls in the python code yet because it needs context, not sure where to get that from?
2008-12-19added "description" and "readonly" properties to RNA Structs (also ↵Campbell Barton
accessible via python) Many descriptions are not written, grep for DOC_BROKEN if you have some spare time to write struct descriptions.
2008-12-03RNA: review of commits in the past days, check the diffs for theBrecht Van Lommel
many small changes, but the two bigger ones are: * Sensors and controllers now use inheritance, rather than pointing to the data in a separate struct. Had to add some new RNA define functionality to support this better. * DNA_meta_types.h was marked as done but still missing many things, now completed.
2008-11-30* changed NULL properties into UnknownPropertyHamed Zaghaghi
* added rna_property.c and rna_actuator * enabled access to properties and actuators from object Note that because we have RNA_Property in the RNA itself, you can find properties in gamelogic of and object under the name of RNA_GameProperty
2008-11-30* controller structs, bController, bExpressionCont and bPythoncont ↵Hamed Zaghaghi
RNFied\n*controllers are available in objects\n* some typos in rna_sensor