Welcome to mirror list, hosted at ThFree Co, Russian Federation.

git.blender.org/blender.git - Unnamed repository; edit this file 'description' to name the repository.
summaryrefslogtreecommitdiff
AgeCommit message (Collapse)Author
2021-08-12Cleanup: use C++ style comments for disabled codeCampbell Barton
2021-07-13Refactor: Move vertex group names to object dataHans Goudey
This commit moves the storage of `bDeformGroup` and the active index to `Mesh`, `Lattice`, and `bGPdata` instead of `Object`. Utility functions are added to allow easy access to the vertex groups given an object or an ID. As explained in T88951, the list of vertex group names is currently stored separately per object, even though vertex group data is stored on the geometry. This tends to complicate code and cause bugs, especially as geometry is created procedurally and tied less closely to an object. The "Copy Vertex Groups to Linked" operator is removed, since they are stored on the geometry anyway. This patch leaves the object-level python API for vertex groups in place. Creating a geometry-level RNA API can be a separate step; the changes in this commit are invasive enough as it is. Note that opening a file saved in 3.0 in an earlier version means the vertex groups will not be available. Differential Revision: https://developer.blender.org/D11689
2021-07-03Cleanup: consistent use of tags: NOTE/TODO/FIXME/XXXCampbell Barton
Also use doxy style function reference `#` prefix chars when referencing identifiers.
2021-06-26Cleanup: full sentences in comments, improve comment formattingCampbell Barton
2021-06-24Cleanup: comment blocks, trailing space in commentsCampbell Barton
2021-05-21Fix some RNA physics accessors creating data.Bastien Montagne
Accessing data through RNA should never implicitely create it. Objects' and particles' forcefields and collision settings were doing this. Note that UI code also had to be tweaked to properly handle `None` (NULL) cases. Differential Revision: https://developer.blender.org/D11341
2021-03-02UI: Clean up labels and descriptions: "Draw" to "Display"William Reynish
In Blender, we used to use the term 'draw' to refer to information displayed to the user. For version 2.80, it was decided to change these instances to 'display' instead. This was to avoid the ambiguity between end-user drawing tools and display options. From the Oxford English Dictionary: - Draw: produce (a picture or diagram) by making lines and marks on paper with a pencil, pen, etc. - Display: show (data or an image) on a computer, television, or other screen. Therefore, we should use draw when referring to drawing tools for making marks, but use display when referring to information shown/displayed to the user. From a user POV, the computer displays certain information, whereas the user draws a mark. Apparently this change was not implemented consistently, so this patch changes all remaining relevant instances of "draw". Differential Revision: https://developer.blender.org/D10551
2021-02-26Cleanup: Clang FormatAaron Carlisle
2021-02-24UI: Clean up "Dupli" to "Instance"Yevgeny Makarov
Following the naming conventions defined in T56648, where in this instance there were still a few remaining uses of the old term. Differential Revision: https://developer.blender.org/D9817
2021-02-24UI: Cleanup and fix labels and descriptions in various placesYevgeny Makarov
Changes include using proper and consistent grammar, simplifying phrasing, using correct terminology, and not including python API identifiers in tooltips. Differential Revision: https://developer.blender.org/D9924
2021-01-29Fix T84588: Set parameter as required for uv_on_emitterRobert Guetzkow
This commit fixes T84588's second issue. The `particle` parameter was declared optional in the Python API of `bpy.types.ParticleSystem.uv_on_emitter` due to a typo in the RNA definition. This commit marks it as required. Reviewed By: JacquesLucke Differential Revision: https://developer.blender.org/D10127
2021-01-22Fix (unreported) LibOverride: hair cache settings not working.Bastien Montagne
Thanks to that same point cache being exposed in **four** different RNA paths (twice in particle system, and twice in its embedded cloth simulation settings). Only way is to also make particle system overridable.
2021-01-13Cleanup: clang-format, trailing spaceCampbell Barton
2021-01-12Fix T84588: Cache access in rna_Particle_uv_on_emitterRobert Guetzkow
The function `rna_Particle_uv_on_emitter` did not handle the case where `particle->num_dmcache` was `DMCACHE_ISCHILD`. This resulted in an incorrect offset for the `mtface` pointer. The commit checks for the case and sets the offset accordingly, similar to existing code in e.g. `particle_calculate_parent_uvs`. Reviewed By: JacquesLucke Differential Revision: https://developer.blender.org/D10072
2020-12-24UI: Cleanup spelling of compound wordsYevgeny Makarov
Approximately 138 changes in the spelling of compound words and proper names like "Light Probe", "Shrink/Fatten", "Face Map". In many cases, hyphens were used where they aren't correct, like "re-fit". Other common changes include: - "Datablock" -> "data-block" - "Floating point" -> "floating-point" - "Ngons" -> "n-gons" These changes help give the language used in the interface a consistent, more professional feel. Differential Revision: https://developer.blender.org/D9923
2020-12-24Cleanup: Fix capitalization in various UI stringsYevgeny Makarov
Approximately 195 changes of capitalization to conform to MLA title style. UI labels and property names should use MLA title case, while descriptions should be capitalized like regular prose, generally with only the start of a sentence capitalized. Differential Revision: https://developer.blender.org/D9922
2020-12-18UI: Don't use abbreviations in label textYevgeny Makarov
Expand abbreviations for words like "Bright" (instead of "Brightness"), "Premul", "Lib", "Dir", etc. Differential Revision: https://developer.blender.org/D9862
2020-12-11UI: Consistent Range DescriptionsYevgeny Makarov
Unifying range descriptions as a value 'to' a value. Differential Revision: https://developer.blender.org/D9771 Reviewed by Julian Eisel
2020-12-10Cleanup: rename BLI_strescape to BLI_str_escapeCampbell Barton
Prepare for `BLI_str_unescape` which doesn't read well without the separator.
2020-12-09Fix T82242: creating particle influence textures does not set up DEGPhilipp Oeser
relation immediately Texture and ParticleSettings have a DEG relation, but `DEG_relations_tag_update` was not called when the texture changed. This lead to no updates when e.g. texture size changes, relation only went into full effect after save/reload or adding/removing keyframes. Two places were additional relation tagging is needed: - ParticleSettings `active_texture` changes - ParticleSettingsTextureSlot (basically any TextureSlots') texture changes Maniphest Tasks: T82242 Differential Revision: https://developer.blender.org/D9393
2020-11-06Cleanup: follow our code style for float literalsCampbell Barton
2020-10-19Spelling: It's Versus ItsHarley Acheson
Corrects incorrect usage of contraction for 'it is', when possessive 'its' was required. Differential Revision: https://developer.blender.org/D9250 Reviewed by Campbell Barton
2020-10-09Fix broken compilation after adding particles DNA defaults.Bastien Montagne
Was failing because of a mismatch between RNA and DNA defaults on `courant_target` property, removed RNA one (DNA came from initial value defined in BKE's particle creation code, think it's best to keep that one).
2020-09-11Particles: Allow python to write hair keysSergey Sharybin
Add a function HairKey.co_object_set() which can be used to modify hair keys positions in a way that hair strands respects the new coordinates, without doing extra trickery with edit mode toggle. The naming comes from existing HairKey.co_object(). The usage is a bit tricky: - The function is to be called on the hair key from an original object. - The arguments are to be passed from evaluated object. Basically: hair_key_orig.co_object_set(object_eval, modifier_eval, particle_eval) This is required because coordinate space conversion needs to know evaluated state of the hair system in order to access hair space matrix. It is a deliberate choice to not pass dependency graph and not to do lookup of evaluated ID on every call of co_object_set() to keep performance on a manageable levels. One requirement is that the hair strands are to be calculated once, by, for example, toggling particle edit mode. Without this there will be no `particles` to access hair keys from in the original object. Such functionality is something what got lost during 2.80 development and is something what is needed here at the studio. Below is the file with more complete example: convert strands from mesh edges to actual particle system hair strands. The viewport refresh is sometimes missing, and this does not seem to be related to this specific change. {F8858104} Differential Revision: https://developer.blender.org/D8849
2020-09-10Fix particle "Mass" option not showing enough precision (appears broken)Julian Eisel
When using the left and right arrows of the number button, the button would seem to do nothing. That is because it modified a value smaller than what is displayed. Show more precision so the button doesn't appear broken.
2020-09-10Fix particle "Loop Count" number button left/right arrows doing nothingJulian Eisel
Was using a step size of 0.1 for an integer. Got caught by sanity assert in UI code.
2020-08-06UI: Fixes and small improvements to some labels and UI messagesYevgeny Makarov
Small tweaks to make labels and texts more correct, consistent and polished. Reviewed by: Aaron Carlisle, Julian Eisel Differential Revision: https://developer.blender.org/D8346
2020-07-22UI: use term 'Vertex' instead of 'Vert'Yevgeny Makarov
2020-07-02UI: Dont abbriviate location & rotationAaron Carlisle
This resolves one of the last few areas where we still use inappropriate abbreviations. Reading abbreviated words is usually slower, because users must parse, guess and translate the words. Using abbreviations such as 'rot' is also especially bad since it's a word in itself too. The main advantage of abbreviations is that they are faster to *write*, which just isn't a concern for text in the UI. Differential Revision: https://developer.blender.org/D8174
2020-06-15Various UI messages fixes...Bastien Montagne
2020-05-08Fix T76498: Refactoring - Rename BKE modifiers funtionsAntonio Vazquez
2020-04-03Code Quality: Replace for loops with LISTBASE_FOREACHDalai Felinto
Note this only changes cases where the variable was declared inside the for loop. To handle it outside as well is a different challenge. Differential Revision: https://developer.blender.org/D7320
2020-04-03Cleanup: Including "BLI_listbase.h" for LISTBASE_FOREACH macroDalai Felinto
These headers are not needed right away, but will be in the upcoming commit.
2020-03-19Cleanup: `make format` after SortedIncludes changeDalai Felinto
2020-03-11Cleanup: spellingCampbell Barton
2020-03-06Cleanup: use 'BKE_' prefix for BKE_deform API callsCampbell Barton
- Use 'BKE_object_defgroup' prefix for object functions. - Rename 'defvert_verify_index' to 'defvert_ensure_index' since this adds the group if it isn't found.
2020-02-06Fix T73620: Diameter Scale was calles 'Radius'William Reynish
This was left over from when the other properties were renamed.
2020-02-05T73589: Code Quality: Renaming on BKE_material.hAntonio Vazquez
Old Name New Name ========= ========= init_def_material BKE_materials_init BKE_material_gpencil_default_free BKE_materials_exit test_object_materials BKE_object_materials_test test_all_objects_materials BKE_objects_materials_test_all give_matarar BKE_object_material_array give_totcolp BKE_object_material_num give_current_material_p BKE_object_material_get_p give_current_material BKE_object_material_get assign_material BKE_object_material_assign assign_matarar BKE_object_material_array_assign give_matarar_id BKE_id_material_array give_totcolp_id BKE_id_material_num assign_material_id BKE_id_material_assign clear_matcopybuf BKE_material_copybuf_clear free_matcopybuf BKE_material_copybuf_free copy_matcopybuf BKE_material_copybuf_copy paste_matcopybuf BKE_material_copybuf_paste BKE_material_init_gpencil_settings BKE_gpencil_material_attr_init BKE_material_add_gpencil BKE_gpencil_material_add BKE_material_gpencil_get BKE_gpencil_material BKE_material_gpencil_default_get BKE_gpencil_material_default BKE_material_gpencil_settings_get BKE_gpencil_material_settings
2020-02-03Merge branch 'blender-v2.82-release'Brecht Van Lommel
2020-02-03Fix Cycles particle hair rendering broken after recent changesBrecht Van Lommel
This code was already wrong, we were just lucky that the previous coordinate was repeated due to using the same memory location.
2020-02-03Merge branch 'blender-v2.82-release'Sergey Sharybin
2020-02-03Fix T73364: crash calling particle_sytem.co_hair() on disabled particlesBrecht Van Lommel
2020-01-31Merge branch 'blender-v2.82-release'Brecht Van Lommel
2020-01-31Fluid: Fixed secondary particle warningsSebastián Barschkis
This commit fixes the warning that bpy_rna.c470 was producing.
2020-01-20Merge branch 'blender-v2.82-release'Campbell Barton
2020-01-20Fixed secondary particle combined export functionalitySebastián Barschkis
The combined export was using the old flag format.
2020-01-17Fix T51289: Particle System UI issue/annoyance: setting Start later than End ↵Danrae Pray
should increase End if necessary, rather than capping it Reviewed By: Luca Rood, Sebastian Parborg, Julian Eisel Differential Revision: http://developer.blender.org/D2701
2020-01-16Cleanup: Clarification of the `Particle.uv_on_emitter()` function docsSybren A. Stüvel
Just some rewording of the documentation of `Particle.uv_on_emitter()`, so that it no longer refers to 'derived mesh' but 'evaluated mesh', and document that it expects a modifier from an evaluated object. No functional changes.
2020-01-16Fix T73121: Blender crashes on accessing particle uv_on_emitterSybren A. Stüvel
Blender wasn't checking whether the passed modifier actually contained an evaluated mesh, before accessing the mesh pointer.
2020-01-08Revert recent change to the particles RNA, and only affect the UI.William Reynish
Even though the name change is more correct, we don't want to change the API at this time.